ReferenceError: _ is not defined - UnderscoreJS
ReferenceError: _ is not defined
    at Object.<anonymous> (D:\vicolinker\xxxxxx.js:31:1)
    at Module._compile (internal/modules/cjs/loader.js:968:30)
    at Object.Module._extensions..js (internal/modules/cjs/loader.js:986:10)
    at Module.load (internal/modules/cjs/loader.js:816:32)
    at Module._load (internal/modules/cjs/loader.js:728:14)
    at Module._load (electron/js2c/asar.js:717:26)
    at Function.Module._load (electron/js2c/asar.js:717:26)
    at Module.require (internal/modules/cjs/loader.js:853:19)
    at require (internal/modules/cjs/helpers.js:74:18)
    at Object.<anonymous> (D:\vicolinker\xxxxxx.js:358:20)

Este error sucede porque no tenemos la librería Underscore instalada, que es un paquete que nos dará soporte para funciones (each, map, reduce, filter, ....) de forma sencilla y poder extender nuestros librerías usando:

_.extend();

Instalación:

Vamos a instalar el paquete dependiendo del gestor de paquetes que estemos usando:

Node.js

npm i underscore 

Meteor.js

meteor add underscore 

Bower

bower install underscore

Luego importamos la librería en nuestro proyecto:

ESM

import _, { map } from 'underscore';

AMD

require(['underscore'], ...)

CommonJS

var _ = require('underscore');
-- o tambien --
const _ = require('underscore');

ExtendScript

#include "underscore.js"

Alternativa:

En caso no quieras usar Underscore otra alternativa seria LodashJS .

https://www.underscorejs.org/

https://www.npmjs.com/package/underscore

https://github.com/jashkenas/underscore/

https://www.lodash.com/

https://www.npmjs.com/package/lodash

https://github.com/lodash/lodash